Something wrong this morning?

This is on the Usage tab - try again just takes you to the account tab. Tried restarting the phone but no difference. Going to log out and back see if that fixes it.

1 Like

Might just be you - working fine for me

1 Like

Morning Colin, did logging out and back in fix it?

1 Like

No, still the same. I’m going to log out, delete the app, and reboot the phone next.

1 Like

Re-installing the app alone should do it; no need to restart your phone! Sorry about the trouble; looking into the details now.

Now I end up with a completely white screen.

Swipe up definitely shows it’s the Zevvle screen I’m looking at

Closed by swiping up and I’m back where I started. I’ll wait and see what you come up with to try next. :+1:

I’m having the same issue this morning too, if that makes any difference?

1 Like

So glad it’s not just me! Might help with finding a fix?
I’m on iOS 12.4.1 on an iPhone X if that helps.

I’ll keep you posted with the fix!

1 Like

@Chalky @Colin have just pushed the fix to production and also cleared the app cache; it should work fine next time you force reopen the app.

The reason for the error was that some charges without a paid_at attribute (e.g. from a manual balance transfer) were loading in the app, which complained there wasn’t a date present. Why it broke this morning is because I changed the way items in the feed are formatted from our server over the weekend. I’ve added an automated test to make sure that doesn’t happen again!

Sorry about the trouble, and anything else do let me know :slight_smile:



All good for me now @nick!

1 Like

Yup, that’s fixed it :+1:
Of course because I’ve deleted & reinstalled the app it’s lost access to Contacts to populate the SMS details but that’s an easy fix.
Thanks for sorting this out :wink: